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4D Trail Mapping | LiDAR, GIS + GPS
Tools for Trail Builders
Overview
This session will give you the ability to plan a trail using LiDAR datasets and basic GIS tools.

Recons to find routes for new trails can be time consuming, and often when out in the field you’ll

find many natural obstacles that don’t appear on contour maps or satellite imagery. Using 3D

LiDAR data you can identify potential areas for establishing trails, and eliminate those areas that

are unsuitable.  This allows your recons to be more targeted on suitable terrain.

You’ll need the following:

1. Desktop computer (Mac or Windows) capable of running QGIS (8 GB of RAM or more)

2. A smartphone with the Trailforks and Gaia GPS apps installed. You should also have at

least free accounts with both Trailforks and Gaia already created. You’ll also learn how

you can increase GPS accuracy using external WAAS receivers.

3. The Theodolite mobile app is also recommended to help determine ground slope when

scouting the route for a new trail.

Process
Planning a new trail is best done with a good working knowledge of the area where the trail is to

be built. You can also use map data to plan a proposed route for a new trail, upload that route to

your smartphone, and then walk that route while recording a GPS track of your recon to help you

determine the final route for the trail. You can take photos to record terrain, obstacles and

features - and these photos will be GPS-tagged and used to revise the new trail’s preliminary

route. The finalized route can then be submitted for approval. The process we’ll be

demonstrating is as follows:

1. Download the DEM GEOTIFF image file from the BC LiDAR portal or other source

2. In QGIS, import the GEOTIFF and create a slope analysis; import existing trails from Trailforks;

import map data from iMAP BC (wildlife habitats and cadastrals)

3. Looking at the slope analysis and 3D terrain models in QGIS, draw a proposed track for the

new trail and export the GPS track as a KML file into Gaia GPS

4. Complete a recon of the track using Gaia GPS, revise the route as needed, then create a PDF

and KML of the final proposed route for submission to the land manager.
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Terminology
● GIS = geographic information system: the software and data used to create maps. Various

GIS platforms are used by surveyors and land managers to create maps and manage data

stored on these maps. This can include vector data like property lines and municipal

boundaries, roads, trails and rivers, and attribute data like names of features and other

information needed by the map user.  ESRI ArcGIS is the most common GIS platform.

● GPS = Geographic Positioning System: a proprietary global navigation satellite system

(GNSS) developed by the US Air Force. Other GNSS services exist, like Russia’s GLONASS

and the European Union’s GALILEO. GPS accuracy is +/- 10m (smartphones and handheld

GPS). GPS accuracy is limited by atmospheric effects and multipath errors (GPS signals

bouncing off terrain, trees and buildings). In North America, WAAS-enabled (Wide Area

Augmentation Service) GPS devices improve accuracy to +/- 3m, but may not reduce

multipath errors.  Surveyors use choke ring antennas to reduce GPS multipath signals.

● Coordinates: GPS typically uses latitude and longitude, but because of the irregularities of

the earth, maps use mapping coordinates (e.g. NAD83 / UTM) to improve local map accuracy;

GIS uses both.

● Waypoint, track, polygon = point on a map; path or multi-segment line; closed shape on a

map. Waypoints are locations on maps that you may wish to avoid or pass through. Tracks

are used to create proposed trails. Polygons are closed shapes on maps that may represent

a particular property, parkland, or a protected area, etc.

● Webmap = web-based mapping service, usually shown to users through a web browser on a

desktop computer or using a smartphone app. Most cities provide webmaps, as does the

province of BC. iMapBC is the BC provincial webmap with information about land usage,

ownership, wildlife and environmentally sensitive areas. This data can be viewed on iMAP

BC, and data can be exported from the map and emailed to you.

● LiDAR = light detection and ranging. An aircraft equipped with a downward-firing laser

scanner captures millions of data points, including the tree and ground layers. LiDAR creates

DSM (digital surface model - treetop level) and DEM (digital elevation model - ground level)

models. The DSM is used for aircraft navigation, and the DEM is used to create contour lines

on maps.

Data Formats
Working with mapping data involves the following common types of files. All but the GEOTIFF are

vector-based file types that generally store 2D data.

● KML = Keyhole Markup Language, the data format used by Google Earth, is used by most

mapping platforms

● GPX = GPS Exchange format, another common file format.
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● OSM = Open Street Maps format, used by the OpenStreetMap Foundation, a public

worldwide mapping database

● SHP = Shapefile, a file format developed by ESRI, used to denote points, tracks or polygons in

maps. SHP files come with SHX and DBF files which provide additional information on top of

the geometry inside the SHP file

● GeoJSON = another open source format for storing mapping data

● GEOTIFF = special grayscale TIF file for storing location and elevation information inside the

image. GEOTIFFs are pixels, not vector geometry like the other formats. Each pixel in the file

is given its map location and elevation above sea level. LiDAR scans can be used to create a

DEM model of terrain, which can be used to build detailed contours on maps, provide slope

analysis, and build 3D models of terrain for investigation.

Planning for a New Trail
As MTB grows in popularity, new trails are needed, but they come with a maintenance price.

New trails should ideally be built within existing trail networks so the new trail can be more easily

maintained by local trail associations.

The first question in planning a new trail is determining who the land manager(s) is. This will

determine the process needed to get approval for the trail. Most trails are on land where one

land manager is responsible for land usage. Some trails may have more than one: NSMBA has

trails overseen by four land managers! If you’re not sure who is the land manager for a particular

area, use the iMap BC webmap and under Data Sources > Add Provincial Layers, add the layer

Administrative Boundaries > ABMS - Municipalities > Municipalities - ABMS - Colour Themed.

Then on the Home tab, click the Identify tool and click the property you want to check. On the

left, expand the entry to see what the Owner Type is.

Land outside of municipal boundaries is most often managed by the province of British Columbia,

and usually by the Ministry of Forests. The agency that’s operationally responsible for provincial

land is FLNRO (Forests, Land and Natural Resource Operations), who oversee industrial and

recreational use of BC’s forests. Trails on these lands require an agreement between a trail

association and the province as described in Section 56 and 57 of the Forest and Range

Practices Act. This agreement is administered by the FLNRO office in a local forestry district; the

entire area from West Vancouver through to Hope and Boston Bar is managed by the Chilliwack

Forest District, whose office is in Chilliwack. Completing a Section 56 or 57 is not an easy

process, and in most cases trail associations have had to wait years to get agreements signed for

new trails.

Proposed new trail routes may be reviewed by first nations to ensure that there are no incursions

on sacred sites or culturally important locations. Proposed new trails are submitted to land

managers (such as FVRD, City of Chilliwack or FLNRO) and usually forwarded to First Nations
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administration for review and approval. If a proposed trail does not receive approval with First

Nations, the trail may not proceed. An archaeological assessment is often required to ensure

that no remains or artifacts are present in the area around the proposed route.

Trails on lands within municipal boundaries are easier to establish, especially if the municipality

supports the trail’s construction. Local MTB trail associations have existing relationships with

municipalities, and in these cases it’s a far easier process to determine if a trail is feasible and

permissible. Whether it is provincial, municipal or even private land, your trail association can

work on advocating for the new trail’s approval by the land manager.

Mapping the Proposed Trail
You may have a good idea where you’d like to locate your new trail, including its route, start and

ends - or you may only have a rough idea of where the trail should go. Looking at maps of the

area can help plan the route, and determine if the trail is feasible.

Mapping Platforms
Various mapping platforms can be used to plan trails. Some are web-based, and others are

desktop-based, and many are both mobile and desktop capable. These are the best as they can

record a track you record to plan a new trail, and allow you to view that track on your desktop.

Trailforks
Trailforks (TF) is the most popular MTB trail mapping service in North America, with a mobile app

and desktop access via web browser. TF allows you to choose several different base maps, and

add layers like slope angle to help in determining trail feasibility. If you create a TF account, you

can plan trail routes using your desktop computer, and record a recon (e.g. exploratory hike)

using the TF app on your phone which you can review on your desktop computer.

Pros: TF is easy to use and shows most existing trails, and along with a desktop computer it is

able to plan most trails.

Cons: using the mobile app outside your home area requires TF Pro (you can still access the TF

website through the browser on your phone). TF only shows map data provided by the platform,

and it can’t import map or GIS data (like property lines). While TF can record a recon, it does not

readily add waypoints or photos into a recon like Gaia GPS.

Gaia GPS
Gaia GPS is an excellent mapping platform similar to TF in that there’s a browser-based version

on desktop and an app for mobile devices. While Gaia is not used much by MTB or trail users, it

is actually a superior trail planning tool to TF, and is recommended for this process. After you’ve

created a free account, you can create folders in Gaia for a new trail, and in this folder store GPS

Page 4



tracks of recons and save GPS-tagged photos of features or obstacles during the recon. On your

desktop, edit your profile to confirm use of Metric units.

At right is Gaia on iOS.  The top buttons are:

1. Fullscreen mode

2. Go to current location

3. Add track recording, waypoint, route, picture, etc.

4. Choose map style (topo, street, etc)

At the bottom of the mobile interface shown at right, click the

Saved button to put tracks/waypoints etc into a folder for the new

trail. You can put waypoints or draw a complete track onto the

map using Gaia on your desktop computer, and then sync it to

your phone.

Pros: desktop version and mobile apps of Gaia GPS are available.

This allows you to review your recon and the photos you took on

your computer. Using Gaia GPS on your computer, you can

import other trails and mapping data needed for planning the

trail.

Cons: TF trails may need to be downloaded for reference. Make

sure you bookmark Gaia on desktop after setting the map style to

meters. Gaia does not have a slope angle layer like TF does.

Users have complained of bugs in the platform.

QGIS
Quantum GIS is a free open-source GIS and

mapping desktop application available for

Windows and Mac OS. QGIS imports all

kinds of map data from various sources, and

accepts the various mapping file types

mentioned above. QGIS can build 2D and

3D map models, both of which are helpful in

planning trails on local hillsides. (At right:

QGIS 3D model of Vedder Mtn showing TF

trails and overlaid coloured wildlife habitat

areas provided by iMap BC.) QGIS is a

powerful tool, but it’s not easy for users who

have had no experience with CAD or GIS.
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Despite this, if it is available in your area, LiDAR data can be used to create a coloured slope

analysis of the terrain in QGIS, greatly aiding the trail planning process.

Pros: Available on MAC or Windows. QGIS is excellent for assembling 2D and 3D map data, as it

can import land boundaries and property lines, park boundaries, and trails from TF. Using LiDAR

data it can build a 3D terrain model under your map data, which can greatly help in planning your

trail. A proposed route can be drawn on top of the coloured slope analysis and exported to Gaia

GPS to be used during the recon.

Cons: complex with a bit of learning curve, and some of the map data QGIS creates (like contours

or slope analysis) cannot be viewed on the trail.

Trail Location, Type and Difficulty
The location of a trail is likely to affect what the trail is used for: cross-country multi-use, technical

MTB downhill, double black DH mountain bike trail, or blue flow trail. A map preview of an area

can help you avoid areas that are incompatible with the trail or can’t be built on at all. The terrain

should match the planned use for the trail. Maps can help you locate areas where the trail can’t

be built (e.g. natural features like a gully or cliff, or privately-owned land).

Grading
Slopes over 30% may make trail

construction difficult - even for

traverse trails. Finding lower slope

areas can be done using the Slope

Angle layer on TF (note that TF

understates slope in most areas -

use QGIS instead). The Chilliwack

Community Forest is shown on the

TF map shown at right with the

slope angle key overlaid on the

map. Some trails have been built

on steeper slopes, and some are

fall-line DH trails with the typical erosion problems associated with these trails.

Land Ownership + Management
If you have not already determined if the land is provincially and/or municipally managed, you

should do so using iMapBC. If you do need private land boundaries for reference, zoom into the

area immediately surrounding the trail, and from the Export tab, choose Provincial Layer

Download to export the land boundaries from iMap BC (in GeoJSON format) and import them into

Gaia for reference.  This will be shown in the QGIS demo.
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Using QGIS with LiDAR Datasets
This document will provide an overview of the steps shown in the demo. Please see the Youtube

video where detailed instructions will be provided.  The following requires a desktop computer.

QGIS is open-source and available for Mac and Windows. The datasets are large, so a fairly

powerful computer is recommended. Typically you will create a QGIS project for each mountain

or trail area you are working on. I would not recommend trying to put your whole trail network

into a single project!  In QGIS ensure your Layers panel is shown under View > Panels > Layers.

Step 1: project setup. Create a folder for your project on your computer, then open QGIS and

immediately save the project into that folder.

Step 2: download DEM datasets. From LiDAR BC download the necessary 1:20000 DEM TIF file

(or files, if your working area spans more than one grid) for your working area, and move it into

the same folder as your QGIS project.  (1:2500 datasets are smaller and less useful).

Step 3: add the GeoTIFF images using Layer > Add layer > Add raster layer. Note: QGIS applies

the specific coordinate reference for the project from the first layer added: typically NAD83 for

provincial LiDAR data. This should allow all other imported data to stack nicely on the TIF image.

Once the TIF is imported, this layer will usually be hidden.

Step 4: add contours. Open Raster > Extraction > Contour. Make sure the input layer is the DEM

TIF file. Set the Interval between contour lines to the desired value (default is 10m, which is fine).

Check “Produce 3D vector” to allow contours to be exported to an external CAD platform as 3D

vectors (if desired). Scroll down to the Contours blank and hit the “…” button and choose “Save to

File” to permanently name and save the contour layer (e.g. “Contours 10m”). Hit “Run” to start the

extraction. In the layers panel, double click the new contours layer. In the Layer Properties

dialog, at left choose Symbology and change the color to black (or as desired). Then at left,

choose Labels. At the top, choose Single Labels from the drop-down, and in the Value

drop-down choose ELEV. Just below this is a white sidebar with options for Text, Formatting,

Buffer, etc. Choose “Text” and make the size 8 points. In the white sidebar area choose Buffer.

Check “Draw text buffer” and make the size 0.8. In the “Placement” section, beside Allowed

positions check “On line” and then uncheck “Above line”. Under Repeating Labels you can set a

distance for repeating the label - start with a value of 80.  Keep this dialog open for the next step.

Step 4b: add primary contours. Making heavier interval contours makes the map easier to read.

At the very left of the contour layer properties dialog, switch to the Symbology panel. At the top

of this dialog, switch from “Single Symbol” to “Rule-Based”. Hit the green “+” icon at the bottom,

and in the Edit Rule dialog make the Label “50m” or “100m” depending on the spacing you’re

planning to use. Make the color black and the Width 0.35 or 0.4 as desired. In the Filter section

put in this exact text: ("ELEV" % 50) = 0.  Replace the 50 with 100 for 100m spacing.
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Step 4c: label primary contours. In the contour labels properties dialog, go to the Labels section

using the left sidebar. At top, switch to Rule-based Labeling. Hit the green “+” icon at the bottom

and beside Description add 50m or 100m depending on the spacing chosen in step 4b. Beside

Filter add ("ELEV" % 50) = 0 replacing with 100m if that is the primary contour spacing desired. In

the bottom left sidebar, for Text choose 8 points, for Buffer check “Draw text buffer” and set Size

to 0.8mm, in Placement for Allowed positions check “On line” and uncheck “Above line”. Scroll

down to Repeating Labels and set Distance to 80.  Hit OK twice to return to the map view.

Step 5: add existing trails. Go to the Trailforks website in your browser and navigate to a riding

area. Choose the Trails tab. Filter trails if required, then at the bottom download the results as a

KML file. Place this KML file in your project folder. In QGIS go to Layer > Add Layer > Add Vector

Layer and for the Source click the “...” button and choose the KML file. Click the “Add” button at

the bottom of the dialog. In the dialog that appears next, choose “Add Layers”. QGIS may display

a coordinate reference confirmation dialog - you can simply hit OK to continue, and QGIS will not

show this dialog again, assuming that the coordinate reference chosen will work for the rest of

the project (and it will).  As you’ve already added the layer to the project, click the Close button.

Step 6: add slope analysis. Choose Raster > Analysis > Slope and under Input layer choose the

DEM tif file used in step 3. Check “Slope expressed as percent instead of degrees”. Scroll down

to the Slope file field, and at the right side, click the “...” button and choose “Save to File” and

save the analysis file into the project folder. You can simply call it “Slope”. Note that this will be a

TIF file. Click the Run button to create the file. The result will be a dark greyscale image that isn’t

useful. In the Layers panel double-click on the slope analysis layer that’s just been created. At

the top of the Symbology panel, switch Render type to “Singleband pseudocolor”. In the Color

ramp drop-down menu, choose “Create new color ramp…” and in this dialog choose “Catalog:

cpt-city”, and in this dialog choose Topography at the left, and then “Elevation” at right. Hit OK to

return to the layer properties dialog. You will see two colour swatches showing the lowest and

highest slope percentages QGIS has found. At the top of the dialog, find the Min and Max values

and enter 0 (zero) and 60 for 0-60% range of colour values that the slope analysis will show. In

the future, you can edit the colourization of the map by double-clicking Slope > Band 1 in the

Layers panel and changing the Max value shown at the top of the Symbology panel. You can edit

the analysis colours and values where the swatches are listed: double-click the value to edit the

number, and double-click the swatch to change the colour associated with that slope value.

Step 7: adding a Hillshade layer. Hillshading renders the topography with precisely oriented

light to simulate shadowing on the terrain. While it’s not as useful for analysis, it’s excellent for

visualization. Choose Raster > Analysis > Hillshade and ensure that the Input layer is the DEM TIF

file. For Azimuth of the light, choose 135 (southeast) or 215 (southwest) for the angle. You can

choose other angles as well, but I recommend those angles to begin with. For Altitude of the

light use 45. Scroll down to the Hillshade field and click “...” at right and choose Save to File.
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Name the file “Hillshade SW” or “Hillshade SE” to indicate the direction of the light. The filename

will become the layer name for this data. You may need to turn off the Slope analysis layer to see

the hillshading depending on the ordering of layers in the Layer panel.

Manage your layer stack
Make sure the trail layer is at the top of the Layers panel, then the contours, and then any raster

images. In general you should stack your layers Trails, Planned Trails, Contours, Slope analysis,

Hillshading, DEM. Drag a layer in the Layers panel to change its stack order. At the top of the

Layers panel is a button that looks like two sheets paper-clipped together - this creates a layer

group so you can turn several layers on and off at once.  You can drag layers in or out of a group.

Adding Cadastral Information to QGIS
It may be useful to look at the general area

where the trail is being proposed on iMap BC

and determine if there are any

environmentally sensitive regions, or private

property near where the trail is to be built.

Under Data Sources > Add Provincial Layers. Add the layers shown above at right. Download

the parcels and WHAs as separate orders so they can be on their own layers. Zoom in enough

so that just the area where you’re planning the trail is shown on the map. With the layers

checked, choose Export > Provincial Layer Download, then at left click “Prepare Order…”. In this

dialog, choose BC Albers, ArcView Shape format, Map Extent/Bounding Box (see the video for

choosing an area using a drawn polygon). Put in your email address and check “I agree”. Save

the zipfile that will be emailed to you and move the folder containing the map data inside the

zipfile (e.g. “PMBC_PARCEL_FABRIC_POLY_SVW”) into your QGIS project folder. In QGIS,

choose Layer > Add Layer > Add Vector Layer and beside “Vector Datasets” click the “...” button

to navigate to this same folder.  Select the .SHP file.

To categorize the parcels so you can visually distinguish between private and public land, double

click on the newly added layer. On the Symbology panel, from the top drop-down menu choose

“Categorized”, choose OWNER_TYPE for the Value, and at the bottom click “Classify” to have

different colours for each type of land owner (double click to edit them). On the Legend panel

(left side, near the bottom), add the Opacity slider to have it appear in the Layers panel so you

can adjust the opacity for the layer.  Repeat this process for the WHA layer.
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Finding new trail routes
The slope colourization of the terrain that QGIS will reveal natural or

man-made features that can assist in planning a new trail. The

dotted line at right was drawn over an overgrown logging spur road

and is being reconned for a new climb trail. QGIS will reveal such

features quickly to help you determine where a new trail could go -

and where it can’t. The image shows high slope areas where

building a trail would be impossible.

Drawing + editing a proposed trail route
If you see a potential location for a new trail, you can draw a line in

QGIS and export it to a GPS app for exploration. You will need to

add a new layer for creating new geometry, so we’ll create a GeoPackage file to store the line

information. Create the layer. Choose Layer > Create Layer > Create New Geopackage Layer

(GPKG layers create fewer files than other kinds of layers). In this dialog, to the right of the

Database field, click the “...” button and add the filename you want for the file - it should relate to

the current project (e.g. “Vedder Climb Trail”). This file can contain multiple lines/routes that you

draw on the map. In the Geometry type drop-down choose “Multiline”. Below this, look for the

coordinates drop-down menu - click it to make the coordinates of this layer the same as the

overall project. Each line you draw will have its info stored in a database inside the GPKG file.

We need a text field added so we can name each proposed route. Under New Field, in the Name

blank put “Name” in the blank with a Maximum length of 80 characters, and click the Add to

Fields List button.  Hit OK to create the layer.

Drawing a route. Make sure this new layer is

selected in the Layers panel. To start drawing,

you must enable layer editing mode by

clicking the yellow pencil icon (red arrow) on

the QGIS toolbar as shown at right. Now click

the Add Line feature button (blue arrow) to

start drawing the line. Each click places a

vertex for the line you are drawing to represent the new proposed

route for a new trail. As shown at right, when you move the cursor to

the next point, a faint dotted line will appear from the last point you

clicked; previous segments will be shown as a thin red line. Lines

can only be edited after you’ve created them. When you’ve created

the final segment, right click to end the line. A dialog will appear: put

in the name you want for this new route.
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Editing a route. Enable layer editing mode. Click the small grey arrow beside the layer edit

button (black arrow, above) and choose “Vertex Tool (current layer)”.  Editing has several modes:

● Hover over a vertex - you will see a circle appear. Click the

circle to move the vertex to a new location. You can also hit

Delete to remove this vertex. Hovering over the start or end

vertex will cause a “+” to appear so you can add a vertex to

lengthen the line

● Hover over the midpoint of a segment and a red “+” will

appear - click it to add a vertex to the line

● Hover over a segment between the mid and endpoints and

the segment will highlight - click to move the segment.

Connecting segments will stretch to suit.

To change the line’s appearance, double-click on the layer to bring up its layer properties. On the

Symbology panel, edit the colour and lineweight to suit. A width of 0.5 will make the line easily

seen on the map.

Exporting to Gaia. Right click on the proposed route’s layer in the Layers panel and choose

Export > Save Features As… and choose KML format. Click the “...” button to the right of file name

to save the KML file for use in Gaia.  At the bottom uncheck “Add saved file to map”.

3D Visualization in QGIS
Click View > 3D Map Views > New 3D Map View. On the toolbar in the 3D view window, click the

rightmost button to turn off docking, which is annoying! Then click the wrench icon to Configure

the 3D view. In the Terrain section of this dialog, under “Type” choose ”DEM”, then in the

Elevation drop-down choose the DEM file. Hit OK. QGIS will generate a 3D view of the terrain.

Use the middle button on your mouse to orbit the view, and the left mouse button to pan. The

right mouse button zooms in and out, as does the mousewheel. You can turn layers on and off in

the Layers panel and that will affect what is shown in the 3D view.
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Recon of Proposed Trail Route - Gaia GPS
You will need a Gaia account (free or paid) for this step. In Gaia on your desktop computer, click

the Import Data button at left and import the KML file into Gaia. On your phone, pull down in the

Saved folder screen of Gaia to download any routes you uploaded on your desktop. Use Gaia to

navigate to the location of your proposed route. During this recon, tap the Record button to save

a track of your recon, taking pictures as needed to help in the finalization of the route.

Revised Route
Review your recon and decide what changes you need to make to the trail’s proposed route. You

can print your route to PDF, and note the latitude and longitude of the trail start and end. You can

place waypoints in Gaia at those locations. Then you can use the Print Map feature on the left for

submitting your proposed trail map via PDF. You may need to submit a GPS track of the route -

once you’ve finalized the route, select and open your route in Gaia, and in the Track panel in

Gaia, scroll down and export the route to KML or GPX format for review by the land manager.

TMI?  Don’t Panic
Here’s a previously recorded video

of using QGIS to import LiDAR data:

https://youtu.be/QhBcNFwux3A

This video shows how the exported

route drawn in QGIS can be

imported into Gaia GPS:

https://youtu.be/C-RABat0tkA

This is a Google Docs document and

will be edited for updates. The link

to this file is here:

https://docs.google.com/document/d/1xdWdGg3maJuJDj56aW04RWlR4RPU8DmcDqyk32pT85Q/

edit?usp=sharing

Speaker Profile
Wes is a director with the Fraser Valley Mountain Bikers Association, and an associate professor

at the University of the Fraser Valley where he teaches architectural design. In his nonexistent

spare time he is the product manager for ShuttleRack, which builds vertical hitch-mounted bike

racks in Chilliwack, BC.  He can be reached at wes@fvmba.com
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